[ Updated threads · New messages · Members · Forum rules · Search · RSS ]
  • Page 1 of 1
  • 1
Forum » Welcome to the [FHSW] Europ Community! » FHSW Corner » FHSW 0.611 Release (FHSW has been updated!)
FHSW 0.611 Release
hakansprayDate: Wednesday, 2020-06-10, 1:29 PM | Message # 1
Private
Group: Trusted
Messages: 10
Awards: 0
Reputation: 0
Status: Offline
http://wbmuse.blog89.fc2.com/blog-entry-212.html (Using google translate worked reasonably)
I presume the EU server won't update as fast as possible either, the japanese will roll out the update on their server the 13th.


aka Hawken (Ingame)
aka Rikskorp (Wiki)
 
mardukDate: Wednesday, 2020-06-10, 4:29 PM | Message # 2
Chief of staff
Group: Admins
Messages: 1568
Awards: 41
Reputation: 12
Status: Offline
Thanks for sharing!

Well, I am happy to see the devs are still working on the mod smile
But we should be aware that introducing it means a lot of work for us, too biggrin


This is a gaming community. People come here to relax. If you start an argument you will get kicked.

Quid pro quo.
 
bubuDate: Wednesday, 2020-06-10, 6:37 PM | Message # 3
Colonel
Group: Admins
Messages: 355
Awards: 27
Reputation: 11
Status: Offline
On topic of fhsw 0.611: in the client folder there are 3 rfa files:
- fall of berlin_001.rfa
- uncompressed_objects.rfa
- westwall-1945_001.rfa

What do we do with these files?
 
hakansprayDate: Wednesday, 2020-06-10, 7:15 PM | Message # 4
Private
Group: Trusted
Messages: 10
Awards: 0
Reputation: 0
Status: Offline
@bubu

I'm not sure what to do with those three files, they are not mentioned in the english readme either as far as I have seen. I installed the new update by first deleting both files in the archive folder with "_001" at the end and then overwriting my 0.61 fhsw folder with new one. Fall of Berlin ran atleast on LAN without doing anything with those files you mentioned but I do not know why they are there.


aka Hawken (Ingame)
aka Rikskorp (Wiki)


Message edited by hakanspray - Wednesday, 2020-06-10, 7:16 PM
 
bubuDate: Wednesday, 2020-06-10, 9:05 PM | Message # 5
Colonel
Group: Admins
Messages: 355
Awards: 27
Reputation: 11
Status: Offline
Right, sounds correct. Today with Marduk we did a little test. He did put both files in his archives folder and that caused his Fall of berlin crash upon loading. So they must not be used on the client it seems happy 

@Troll/e-3/radio: Before updating server with 0.611, do we need to do anything with the current SSMs or can they be used with the new files?

Also, there is now a korsun pocket map, could anyone please verify whether it is from older version or whether they actually fixed korsun?
 
hakansprayDate: Thursday, 2020-06-11, 8:12 AM | Message # 6
Private
Group: Trusted
Messages: 10
Awards: 0
Reputation: 0
Status: Offline
@bubu

I launched Korsun Pocket and it worked, flags could be capped etc. Although I do not know if it would be different running the map on an dedicated server. I don't know how reliable it is but checking "last time changed" says Korsun Pocket is from 2016 september 24th, which I do believe is accurate since I installed the update properly and other files that have been overwrited at the same time also have different dates for "last time changed".

Added (2020-06-11, 1:27 PM)
---------------------------------------------
Playing Korsun Pocket alone on the test server for 0.611 worked also.


aka Hawken (Ingame)
aka Rikskorp (Wiki)
 
GameplayerDate: Thursday, 2020-06-11, 3:14 PM | Message # 7
Silver Donator
Group: Gold Donator
Messages: 91
Awards: 10
Reputation: 6
Status: Offline
@bubu. I wonder can we get the link in moddb. I don't trust to unknown links anymore. I just want to know that is it safe to use when we update the server?
Another thing. Can you check does it has monster des stahles map? And If it does have it. Does it have the old super yamato battleship on japanese side. It is called "Kii". That would be awesome.


Hates too quick judgement.

aka Gameplayer or Gameplayer500


Message edited by Gameplayer - Thursday, 2020-06-11, 3:16 PM
 
hakansprayDate: Thursday, 2020-06-11, 3:51 PM | Message # 8
Private
Group: Trusted
Messages: 10
Awards: 0
Reputation: 0
Status: Offline
@Gameplayer

The monster des stahles map has been updated, among other smaller changes the Super Yamato is once again there. I found Kii on the map when playing it offline.

Also you can go directly to the offical fhsw blog using your browser or the link on this website if you do not want to click on unknown links.


aka Hawken (Ingame)
aka Rikskorp (Wiki)


Message edited by hakanspray - Thursday, 2020-06-11, 3:59 PM
 
bubuDate: Thursday, 2020-06-11, 4:37 PM | Message # 9
Colonel
Group: Admins
Messages: 355
Awards: 27
Reputation: 11
Status: Offline
Quote hakanspray ()
Playing Korsun Pocket alone on the test server for 0.611 worked also.
Thanks Hawken!

Quote Gameplayer ()
I wonder can we get the link in moddb. I don't trust to unknown links anymore. I just want to know that is it safe to use when we update the server?
I will email eye.ris if he can add it smile
 
MAJORMASTERBATESDate: Friday, 2020-06-12, 5:59 PM | Message # 10
Sergeant
Group: Bronze Donator
Messages: 30
Awards: 2
Reputation: 0
Status: Offline
Can anyone confirm if the S&W pack works with this or if its needed anymore?
 
MAJORMASTERBATESDate: Friday, 2020-06-12, 10:42 PM | Message # 11
Sergeant
Group: Bronze Donator
Messages: 30
Awards: 2
Reputation: 0
Status: Offline
Either i'm doing something wrong or S&T pack doesn't work now i get CTD sad
 
MAJORMASTERBATESDate: Sunday, 2020-06-14, 1:01 PM | Message # 12
Sergeant
Group: Bronze Donator
Messages: 30
Awards: 2
Reputation: 0
Status: Offline
radiosmersh has said it's incompatible with new release for anyone else getting this problem.
 
starking018Date: Friday, 2020-06-19, 3:22 PM | Message # 13
Colonel
Group: Friends
Messages: 350
Awards: 20
Reputation: 9
Status: Offline
Quote MAJORMASTERBATES ()
radiosmersh has said it's incompatible with new release for anyone else getting this problem.
It has been updated since: http://www.fhsw-europe.com/forum/34-832-1
Quote bubu ()
On topic of fhsw 0.611: in the client folder there are 3 rfa files:
- fall of berlin_001.rfa
- uncompressed_objects.rfa
- westwall-1945_001.rfa

What do we do with these files?
In short, players should ignore these and not put them anywhere in the Battlefield folders, unless they know what they are doing, otherwise they can cause crashes and lag.
As eYe.ris said on Discord, Fall_of_berlin_001.rfa and westwall-1945_001.rfa add lightmaps to these maps, which can improve graphics quality at the expense of higher resource requirements (GPU and memory). I'd caution that you can expect lower framerates and perhaps more crashes due to higher memory use.
Uncompressed_objects.rfa is for modders only and players should not put it anywhere inside the game's folders.


I've so far tested all standard FHSW 0.611 maps (I have not tested the mappack ones yet) with the SSMs which I have for them (excluding Breakthrough-1944's, Seelow-Heights-1945's and Westminster-1942's SSMs) for basic stability (loading on the server and 1 client, 2 minute rounds). This limited test revealed only a couple of potential problems, which already existed in 0.61, and may not occur on every configuration:
  • Operation_Hailstone: My game client sometimes crashes on loading (has happened here in 0.61 too). Server crashed when going to the next map (happened here in 0.61 too). Looks like it's an OS-dependent bug which our main server seems unaffected by. Restarts may be risky too, but now we can do without restarts.
  • Salerno-1943: Same OS-dependent bug as above, when going to the next map.
  • Alaska-1948: (copied from the SSM thread) Readme says "Weapons embedded in the map have been re-examined and stability in multiplayer has been slightly improved." and "YaK-9P has been changed to YaK-9UT". So our SSM will need to be reconciled. The map still has stability problems, seemingly OS-dependent. I tested the map a little and had a client crash on capturing the first flag (has happened in past versions too). Then I restarted the map and that caused the server to crash (32-bit Windows). On Kabu.server (Linux) it seems to crash when switching to the next map, so it loads the same map again (they're trying to fix it). However, siwasu reported that the map didn't crash on another Windows server it was tested on, so it's worth trying to play the map (at least when an admin is watching). And without the SSM please, until it is reconciled with 0.611.
    Basically, from this limited testing I didn't detect a map or a SSM which was too unstable to risk trying to run it on our main server (under Windows).

    We need to further check the mappack maps and Kakazu_Ridge-1945 & Kushira.
    Kakazu_Ridge-1945 and Kushira are still unchanged from FHSW 0.6 and FHSW 0.61, respectively. So it seems unlikely that they'd be stable now, unless all their problems were caused by the buggy kits causing crashes when pressing 7, or another one of the bugs which were fixed in FHSW 0.611. Kabu.server did not run them during version 0.61, because the maps were replaced by the custom Kakazu_Ridge-1945_CM201811 and kushira_day2. I now see that, strangely, Kakazu_Ridge-1945 and Kushira are once again included in Kabu.server's map list, along with the custom versions. I guess they won't actually try to play them - maybe they only want to test them (as they did with Alaska, which they had excluded during 0.61, then tested with 0.611 and excluded again for now). I don't really know what the situation is with Kakazu_Ridge-1945 & Kushira, but I can try to find out. But my suggestion still is to just add and start playing both Kakazu_Ridge-1945_CM201811 and kushira_day2 in a new mappack version (assuming that they pass testing). As a reminder, Bubu distributed an older, incompatible version of Kushira in Mappack3_version3.1, so there must be some players who would crash if they tried to load Kushira even if it has somehow been fixed in FHSW 0.611. On the other hand, with kushira_day2 at least they'd get a "Map not found" if they don't update the mappack (and I suppose it'd be more stable than Kushira from 0.61/0.611).


    Also, I saw a few players complain about low framerates since they updated to 0.611. If you saw such symptoms, please provide more info, such as: how you updated (overwrote 0.61 or deleted and reinstalled); did you add or replace anything in FHSW, FH and BF1942, such as S&T packs for FHSW, FH, ragdoll animations, HD remaster. Most players didn't experience any new problems from FHSW 0.611, so I don't know what the cause is, yet.

    Air Troll a.k.a. starking018
  •  
    Forum » Welcome to the [FHSW] Europ Community! » FHSW Corner » FHSW 0.611 Release (FHSW has been updated!)
    • Page 1 of 1
    • 1
    Search: